PHP в деталях



         

Комментарии к статье "" - часть 5


table width="100%" cellpadding="0" cellspacing="0" >12.6.2001 17:08  Lom  []

Тьфу, перепутал.

Хотел сказать, что в 1.3.14 (1.3.12) такого не было.

А у кого там с SMTP проблема? Поставьте ПХП новее. В какой-то 4-й версии отправка почты не работала. Это официальная информация от разработчиков.

14.6.2001 17:43  Nic  []

Масса благодарностей! Копался по инету и никак не мог РНР привернуть к апачу, мож кнешно не очень разбираюсь, но по изложенным рекомендация все получилось!!! Ещё раз спасибо!

15.6.2001 13:07  Дмитрий  []

Ну вот. Установил все КАК НАПИСАНО. После этого Апач перестал запускаться...

Причина банальная - разные слэши в виндовых и юниксовых путях.

В статье НАПИСАНО:

LoadModule php4_module "f:/usr/local/php/php4apache.dll"

А оказалось (у меня под Win'98 SE)

LoadModule php4_module "D:Program Filesphp4php4apache.dll"

Может кому-нибудь поможет... А-то напугаете: Апач де не той версии, ищет не там...

P.S.

Остальные пути в httpd.conf (которые проставил сам Апач) прописаны с юниксовыми слэшами, но все прекрасно работает :)

18.6.2001 16:25  Fakir  []

Да, несомненно, PHP как модуль Apache несомненно радует :) Но вот некоторые проблемы все таки есть :( В том числе встретился с такой:

Конфигурация: WinNT+PHP(как модуль)

Скриптик:

header ("Content-type: image/jpeg");

$path="image.jpg";

$im=fopen("$path", "r");

fpassthru($im);

Ожидаемый результат: Должна выводиться картинка image.jpg

Проблема: Не работает!!!

Конфигурация: WinNT+PHP(как CGI)

Скриптик:

Тот же самый

Ожидаемый результат: Должна выводиться картинка image.jpg

Проблема: Нет проблем, работает! картинку выводит!

Вчем проблема, почему не работает когда PHP подключен как модуль :((

Заранее благодарен!!!

23.6.2001 23:33  faeton  []

2CyberCop: По поводу extensions и Win2k. Проблема в том, что когда PHP переставили, как модуль, то в php.ini нужно прописывать абсолютные пути, то есть если раньше extension_dir был, допустим, "ext", то теперь он должен быть "z:/usr/local/php/ext".

3.7.2001 19:51  Partizan  []

Уважаемый автор статьи ... Я все зделал как написано, ПХП работает и ошибок вроде не выдает, но такой вот скрипт не работает вообще

function foo ($in) {

if ($in !="") {$out=$in;}

else {$out="02.07.01/main";} return $out;}?>

А у моего хостинг провайдера работает ... Вы не подскажите в чем может быть дело?

С Уважением

Partizan

<


Содержание  Назад  Вперед