PHP в деталях


         

Комментарии к статье "" - часть 8


table width="100%" cellpadding="0" cellspacing="0" >7.12.2001 23:18  Alexey  []

Я уже давно установил себе Apache вместе с PHP b MySQL если, кто хочет совета могу дать.

Мой Апачевский сайт: http://takonet.co.il

Удачи Всем!

8.12.2001 17:10  redbaron  []

иногда помогает

(когда прикручиваеш модуль) дополнительная строчка:

AddModule mod_php4.c

у меня без этого не работала(хотя раньше все получалось)

18.12.2001 16:12  ss

Упоминаемая статья была написана еще ооочень давно, когда ПХП4 и возможности установить ее как модуль не было и в помине. AddModule mod_php4.c - это явно Апач 1.3.22, который по дефолту использует директиву ClearModules.

2.1.2002 21:05  hooky-mars  []

В первый раз запуска появилось "Apache/1.3.12 (Win32) PHP/4.0.1pl1 running... ". Только до этого небыло найде но несколько dll библиотек, в следствии чего програ вырубилась. А после вообще неработает пишет что-то про фаил httpd.pid. Помагите люди!

У меня Apache 1.3.20.

9.1.2002 13:16  Dmitry Dudin  []

Все заработало!

Apache 1.3.22 + PHP 4.1.1 as module

Необходимо прописать в httpd.conf следующее:

в секцию...

# Dynamic Shared Object (DSO) Support

LoadModule php4_module "d:/web/php/sapi/php4apache.dll"

AddModule mod_php4.c

в секцию...

<IfModule mod_mime.c>

AddType application/x-httpd-php .php .phtml .php4

</IfModule>

6.2.2002 22:32  afandi  []

Вот такой глюк

[Wed Feb 06 22:20:41 2002] [warn] Loaded DSO c:/winnt/system32/php4apache.dll uses plain Apache 1.3 API,

this module might crash under EAPI! (please recompile it with -DEAPI)

вчем проблема. должен отметить арачи ставил вместе с ораклом

1.5.2002 12:58  Kobold

А возможно ли установить ПХП таким образом если Апач второй версии?

15.5.2002 13:04  VARGGOTH  []

1)у меня токой глюк возник:пхпшные скрипты работают тока в корневом каталоге сайта,как с этим бороться?

2)Как заставить пхпшные скрипты отсылать почту?

Ответ DL:

1) очень интересный глюк. :) 2) нужен sendmail под windows.

6.6.2002 13:31  cherry  []

Apache 1.3.3 + PHP 4.2.1

php свежескачаный

Ставлю под НТ

Такая ошибка :(

httpd: module "c:php4buildsnapsapiapachemod_php4.c" is not compatible with

this version of Apache.

Что скажут гуру?

<


Содержание  Назад  Вперед